快捷搜索:  as  2018  FtCWSyGV  С˵  test  xxx  Ψһ  w3viyKQx

玛雅娱乐官方登录:64位Eclipse运行时提示“Failed to load the JNI shared library Javajre6binclientjvm.dll”的解决方案



因为开拓情况改变,改用64位Juno 64位 SP1情况调换了原本的Juno 32位。结果启动Eclipse报错:

"Failed to load the JNI shared library “E:2000JavaJDK玛雅娱乐官方登录6bin..jrebinclientjvm.dll”

其他情况要用到默认的JDK 1.6.0_37 32位,默认并设置设置设备摆设摆设在默认变量JAVA_HOME中,路径为E:2000JavaJDK6。

于是新装JDK 1.6.0_37 64位,路径为E:2000JavaJDK64,启动Eeclipse再次报错,同上。

仔细想想,Eclipse启动时应该会先从本身设置设置设备摆设摆设中先探求JVM,于是在Eclipse.ini中增添两行:

-vm

E:2000JavaJDK64binjavaw.exe

依然掉足,同上。于是索性将系统情况变量中,JAVA_HOME设置为:E:2000JavaJDK64。此次能够正常启动了,可是,其他系统要用32位的时刻,又报同样差错。仔细查看Eclipse.ini,发明OpenFile后增添了如下项:

-vm

E:/2000/Java/JDK64/bin/javaw.exe

而我原本是加在文件末端,位置差错,以是没有生效。(邀月注:着实将原本两行放在OpenFile后也可以。)于是,将JAVA_HOME从新设置为:E:2000JavaJDK6

再考试测验用E:2玛雅娱乐官方登录000Javaeclipseeclipse.exe -玛雅娱乐官方登录clean -nl en_US 从新启动Eclipse ,结果报错:JVM Terminated.玛雅娱乐官方登录 Exit code=-1

仔细查看,斟酌可能是内存参数问题:

将:

-vmargs

-Dosgi.requiredJavaVersion=1.5

-Dhelp.lucene.tokenizer=standard

-Xms40m

-Xmx512m

改动为:

-vmargs

-Dosgi.requiredJavaVersion=1.5

-Dhelp.lucene.tokenizer=standard

-Xms40m

-Xmx256m

从新启动,终于正常。

启动正常后,再改回512M,依然可以正常启动Eclipse。彷佛Eclipse已经&玛雅娱乐官方登录ldquo;智慧”地记着了精确的设置设置设备摆设摆设。

您可能还会对下面的文章感兴趣: